From d62d274fb3ac420ff2c77adbc2fc82bd7ec5f902 Mon Sep 17 00:00:00 2001
From: Alex Griffin
Date: Wed, 29 May 2019 11:43:10 -0500
Subject: [PATCH] nongnu: linux-firmware: Use Ambrevar's build system instead.
* nongnu/packages/linux.scm: Replace probably-redundant copyright attributions
with Pierre Neidhardt instead.
(linux-firmware): Use his build system instead of the one from Andy Wingo's
guix-nonfree repository.
---
nongnu/packages/linux.scm | 14 ++++----------
1 file changed, 4 insertions(+), 10 deletions(-)
diff --git a/nongnu/packages/linux.scm b/nongnu/packages/linux.scm
index 65648f9..4d01dba 100644
--- a/nongnu/packages/linux.scm
+++ b/nongnu/packages/linux.scm
@@ -1,11 +1,5 @@
;;; Copyright © 2019 Alex Griffin
-;;; Copyright © 2012, 2013, 2014, 2015, 2017, 2018 Ludovic Courtès
-;;; Copyright © 2013, 2014 Andreas Enge
-;;; Copyright © 2012 Nikita Karetnikov
-;;; Copyright © 2014, 2015 Mark H Weaver
-;;; Copyright © 2015 Federico Beffa
-;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer
-;;; Copyright © 2015, 2017, 2018 Andy Wingo
+;;; Copyright © 2019 Pierre Neidhardt
;;;
;;; This program is free software: you can redistribute it and/or modify
;;; it under the terms of the GNU General Public License as published by
@@ -94,9 +88,9 @@ on hardware which requires nonfree software to function.")))
#:builder (begin
(use-modules (guix build utils))
(let ((source (assoc-ref %build-inputs "source"))
- (fw-dir (string-append %output "/lib/firmware/")))
- (mkdir-p fw-dir)
- (copy-recursively source fw-dir)
+ (destination (string-append %output "/lib/firmware")))
+ (mkdir-p destination)
+ (copy-recursively source destination #:follow-symlinks? #t)
#t))))
(home-page
"http://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git")