docker-node-red/docker.nix
James Andariese aa3999b352
Some checks failed
Build and push nixos-based docker container / build (push) Has been cancelled
fix stale repo issue affecting scheduled jobs
2024-08-03 23:27:54 -05:00

21 lines
349 B
Nix

{ config, pkgs, ...}:
let
name = "node-red";
entrypoint = pkgs.writeShellApplication {
inherit name;
runtimeInputs = with pkgs; with nodePackages; [
node-red
ungoogled-chromium
];
text = ''
node-red
'';
};
in pkgs.dockerTools.streamLayeredImage {
inherit name;
config.Cmd = [ "${entrypoint}/bin/entrypoint" ];
}