add garage tank mount open up the firewall on the k3s agents for now apply this to xerneas (yveltal doesn't have an hdd)
15 lines
429 B
Nix
15 lines
429 B
Nix
{ config, ... }:
|
|
{
|
|
# make an LV for the tank. add VGs to it.
|
|
# parted /dev/sda
|
|
# stuff to make this for lvm.
|
|
# vgcreate xerneas-tank-hdd /dev/sda1
|
|
# lvcreate -l 50%FREE xerneas-tank-hdd --name garage-data
|
|
# mkfs.xfs -L xerneas-gdat /dev/mapper/xerneas--tank--hdd-garage--data
|
|
|
|
fileSystems."/var/lib/garage/data" = {
|
|
device = "/dev/mapper/xerneas--tank--hdd-garage--data";
|
|
fsType = "xfs";
|
|
};
|
|
}
|