nixos/modules/packages.nix
2024-07-31 00:18:30 -05:00

45 lines
723 B
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

# Edit this configuration file to define what should be installed on
# your system. Help is available in the configuration.nix(5) man page
# and in the NixOS manual (accessible by running nixos-help).
{ config, pkgs, lib, flake-inputs, ... }:
{
environment.systemPackages = with pkgs; [
seatd
#emacs-nox
inetutils
unzip
buildah
curl
vim
neovim
wget
sshfs
dig
gost
elinks
#dislocker
#ntfs3g
kubectl
sops
git
bc
pciutils
usbutils
file
htop
brightnessctl
kubernetes-helm
ripgrep
bridge-utils
nettools
psmisc
nixos-generators
];
programs.mtr.enable = true;
programs.tmux.enable = true;
}