This patch moves Guile modules shipped as a Guix channel under the modules directory. The rationale behind this is that we are probably adding unwanted files into Guile's load path, such as the news file and possible scripts that could be added to the channel repository in the future. * guix-channel (channel): Set directory field. * nongnu/*: Move under modules/nongnu. * nonguix/*: Move under modules/nonguix.
24 lines
987 B
Diff
24 lines
987 B
Diff
See comment in gnu/build/icecat-extension.scm.
|
|
|
|
diff --git a/toolkit/mozapps/extensions/internal/XPIDatabase.sys.mjs b/toolkit/mozapps/extensions/internal/XPIDatabase.sys.mjs
|
|
index 0b885f6..0bbfbee 100644
|
|
--- a/toolkit/mozapps/extensions/internal/XPIDatabase.sys.mjs
|
|
+++ b/toolkit/mozapps/extensions/internal/XPIDatabase.sys.mjs
|
|
@@ -3607,6 +3607,7 @@ export const XPIDatabaseReconcile = {
|
|
if (
|
|
newAddon ||
|
|
oldAddon.updateDate != xpiState.mtime ||
|
|
+ oldAddon.path != xpiState.path ||
|
|
(aUpdateCompatibility && this.isAppBundledLocation(installLocation))
|
|
) {
|
|
newAddon = this.updateMetadata(
|
|
@@ -3615,8 +3616,6 @@ export const XPIDatabaseReconcile = {
|
|
xpiState,
|
|
newAddon
|
|
);
|
|
- } else if (oldAddon.path != xpiState.path) {
|
|
- newAddon = this.updatePath(installLocation, oldAddon, xpiState);
|
|
} else if (aUpdateCompatibility || aSchemaChange) {
|
|
newAddon = this.updateCompatibility(
|
|
installLocation,
|