nonguix/nongnu/packages/patches/pinephone-0008-bootsplash.patch
Petr Hodina d6fa79a01b nongnu: Add linux-pinephone and linux-pinephone-pro.
* nongnu/packages/linux.scm (linux-pinephone-urls, pinephone-linux, linux-pinephone, linux-pinephone-pro): New variables.
* nongnu/packages/patches/linux-pinephone-pro-defconfig-guix-fix.patch: New
file.
* nongnu/packages/patches/pinephone-0001-bootsplash.patch: New file.
* nongnu/packages/patches/pinephone-0002-bootsplash.patch: New file.
* nongnu/packages/patches/pinephone-0003-bootsplash.patch: New file.
* nongnu/packages/patches/pinephone-0004-bootsplash.patch: New file.
* nongnu/packages/patches/pinephone-0005-bootsplash.patch: New file.
* nongnu/packages/patches/pinephone-0006-bootsplash.patch: New file.
* nongnu/packages/patches/pinephone-0007-bootsplash.patch: New file.
* nongnu/packages/patches/pinephone-0008-bootsplash.patch: New file.
* nongnu/packages/patches/pinephone-0009-bootsplash.patch: New file.
* nongnu/packages/patches/pinephone-0010-bootsplash.patch: New file.
* nongnu/packages/patches/pinephone-0011-bootsplash.patch: New file.
* nongnu/packages/patches/pinephone-drop-modem-power-node.patch: New file.
* nongnu/packages/patches/pinephone-fbcon-remove-no-op-fbcon_set_origin.patch: New file.
* nongnu/packages/patches/pinephone-pro-add-modem-ri.patch.patch: New file.
* nongnu/packages/patches/pinephone-pro-remove-modem-node.patch: New file.
* nongnu/packages/patches/pinephone-revert-fbcon-remove-now-unusued-softback_lines-cursor-argument.patch: New file.
* nongnu/packages/patches/pinephone-revert-fbcon-remove-soft-scrollback-code.patch: New file.

asd
2023-01-14 09:09:46 +01:00

22 lines
588 B
Diff

diff --git a/drivers/tty/sysrq.c b/drivers/tty/sysrq.c
index 3ffc1ce29023..bc6a24c9dfa8 100644
--- a/drivers/tty/sysrq.c
+++ b/drivers/tty/sysrq.c
@@ -49,6 +49,7 @@
#include <linux/syscalls.h>
#include <linux/of.h>
#include <linux/rcupdate.h>
+#include <linux/bootsplash.h>
#include <asm/ptrace.h>
#include <asm/irq_regs.h>
@@ -104,6 +105,8 @@ static void sysrq_handle_SAK(int key)
{
struct work_struct *SAK_work = &vc_cons[fg_console].SAK_work;
schedule_work(SAK_work);
+
+ bootsplash_disable();
}
static struct sysrq_key_op sysrq_SAK_op = {
.handler = sysrq_handle_SAK,