* nongnu/packages/linux.scm (linux-pinephone-urls, pinephone-linux, linux-pinephone, linux-pinephone-pro): New variables. * nongnu/packages/patches/linux-pinephone-pro-defconfig-guix-fix.patch: New file. * nongnu/packages/patches/pinephone-0001-bootsplash.patch: New file. * nongnu/packages/patches/pinephone-0002-bootsplash.patch: New file. * nongnu/packages/patches/pinephone-0003-bootsplash.patch: New file. * nongnu/packages/patches/pinephone-0004-bootsplash.patch: New file. * nongnu/packages/patches/pinephone-0005-bootsplash.patch: New file. * nongnu/packages/patches/pinephone-0006-bootsplash.patch: New file. * nongnu/packages/patches/pinephone-0007-bootsplash.patch: New file. * nongnu/packages/patches/pinephone-0008-bootsplash.patch: New file. * nongnu/packages/patches/pinephone-0009-bootsplash.patch: New file. * nongnu/packages/patches/pinephone-0010-bootsplash.patch: New file. * nongnu/packages/patches/pinephone-0011-bootsplash.patch: New file. * nongnu/packages/patches/pinephone-drop-modem-power-node.patch: New file. * nongnu/packages/patches/pinephone-fbcon-remove-no-op-fbcon_set_origin.patch: New file. * nongnu/packages/patches/pinephone-pro-add-modem-ri.patch.patch: New file. * nongnu/packages/patches/pinephone-pro-remove-modem-node.patch: New file. * nongnu/packages/patches/pinephone-revert-fbcon-remove-now-unusued-softback_lines-cursor-argument.patch: New file. * nongnu/packages/patches/pinephone-revert-fbcon-remove-soft-scrollback-code.patch: New file. asd
22 lines
734 B
Diff
22 lines
734 B
Diff
diff --git a/drivers/video/fbdev/core/fbcon.c b/drivers/video/fbdev/core/fbcon.c
|
|
index 9a39a6fcfe98..8a9c67e1c5d8 100644
|
|
--- a/drivers/video/fbdev/core/fbcon.c
|
|
+++ b/drivers/video/fbdev/core/fbcon.c
|
|
@@ -1343,6 +1343,16 @@ static void fbcon_cursor(struct vc_data *vc, int mode)
|
|
int y;
|
|
int c = scr_readw((u16 *) vc->vc_pos);
|
|
|
|
+ /*
|
|
+ * Disable the splash here so we don't have to hook into
|
|
+ * vt_console_print() in drivers/tty/vt/vt.c
|
|
+ *
|
|
+ * We'd disable the splash just before the call to
|
|
+ * hide_cursor() anyway, so this spot is just fine.
|
|
+ */
|
|
+ if (oops_in_progress)
|
|
+ bootsplash_disable();
|
|
+
|
|
ops->cur_blink_jiffies = msecs_to_jiffies(vc->vc_cur_blink_ms);
|
|
|
|
if (fbcon_is_inactive(vc, info) || vc->vc_deccm != 1)
|