* nongnu/packages/linux.scm (linux-pinenote): New variable. * nongnu/configs/pinenote_config: New file. * nongnu/configs/pinenote_defconfig: New file. * nongnu/configs/quartz64_defconfig: New file. * nongnu/configs/quartz64b_defconfig: New file. * nongnu/packages/patches/0001-Rudimentary-attempt-to-keep-PMIC-usable-after-suspen.patch: New file. * nongnu/packages/patches/battery-level.patch: New file. * nongnu/packages/patches/pinenote-battery-level.patch: New file. * nongnu/packages/patches/pinenote-rockchip-ebc-patches-mw.patch: New file. * nongnu/packages/patches/pinenote-touchscreen-1.patch: New file. * nongnu/packages/patches/pinenote-touchscreen-2.patch: New file. * nongnu/packages/patches/pinenote_defconfig.patch: New file. * nongnu/packages/patches/rk3566-pinenote_dtsi.patch: New file. * nongnu/packages/patches/rockchip_ebc_addition_extract_fbs.patch: New file. * nongnu/packages/patches/rockchip_ebc_mw_20220624.patch: New file. * nongnu/packages/patches/rockchip_ebc_patches_mw_20220712.patch: New file. * nongnu/packages/patches/rockchip_ebc_patches_mw_20220730.patch: New file. * nongnu/packages/patches/rockchip_ebc_patches_mw_20220804.patch: New file. * nongnu/packages/patches/rockchip_ebc_patches_mw_20220808.patch: New file. * nongnu/packages/patches/sdbus-cpp-remove-systemd.patch: New file. * nongnu/packages/patches/touchscreen-driver-01.patch: New file. * nongnu/packages/patches/touchscreen-driver-02.patch: New file. * nongnu/packages/patches/wusb3801_patches_samsapti_20220725.patch: New file.
66 lines
1.6 KiB
Diff
66 lines
1.6 KiB
Diff
diff --git a/arch/arm64/boot/dts/rockchip/rk3566-pinenote-v1.2.dts b/arch/arm64/boot/dts/rockchip/rk3566-pinenote-v1.2.dts
|
|
index 6bbc4c675d..92ef19676e 100644
|
|
--- a/arch/arm64/boot/dts/rockchip/rk3566-pinenote-v1.2.dts
|
|
+++ b/arch/arm64/boot/dts/rockchip/rk3566-pinenote-v1.2.dts
|
|
@@ -16,3 +16,39 @@ &pmu_io_domains {
|
|
&spk_amp {
|
|
VCC-supply = <&vcc_bat>;
|
|
};
|
|
+
|
|
+&usb2phy0_otg {
|
|
+ port {
|
|
+ usb2phy0_typec_hs: endpoint {
|
|
+ remote-endpoint = <&usbc_hs>;
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&wusb3801 {
|
|
+ status = "okay";
|
|
+
|
|
+ connector {
|
|
+ compatible = "usb-c-connector";
|
|
+ label = "USB-C";
|
|
+ vbus-supply = <&otg_switch>;
|
|
+ power-role = "dual";
|
|
+ try-power-role = "sink";
|
|
+ data-role = "dual";
|
|
+ typec-power-opmode = "default";
|
|
+ pd-disable;
|
|
+
|
|
+ ports {
|
|
+ #address-cells = <0x01>;
|
|
+ #size-cells = <0x00>;
|
|
+
|
|
+ port@0 {
|
|
+ reg = <0x00>;
|
|
+
|
|
+ usbc_hs: endpoint {
|
|
+ remote-endpoint = <&usb2phy0_typec_hs>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|
|
diff --git a/arch/arm64/boot/dts/rockchip/rk3566-pinenote.dtsi b/arch/arm64/boot/dts/rockchip/rk3566-pinenote.dtsi
|
|
index 59ac178881..e5ab58cbc0 100644
|
|
--- a/arch/arm64/boot/dts/rockchip/rk3566-pinenote.dtsi
|
|
+++ b/arch/arm64/boot/dts/rockchip/rk3566-pinenote.dtsi
|
|
@@ -6,6 +6,7 @@
|
|
#include <dt-bindings/leds/common.h>
|
|
#include <dt-bindings/pinctrl/rockchip.h>
|
|
#include <dt-bindings/suspend/rockchip-rk3568.h>
|
|
+#include <dt-bindings/usb/pd.h>
|
|
|
|
#include "rk3566.dtsi"
|
|
|
|
@@ -611,7 +612,7 @@ wusb3801: tcpc@60 {
|
|
interrupts = <RK_PA4 IRQ_TYPE_LEVEL_LOW>;
|
|
pinctrl-0 = <&tcpc_int_l>;
|
|
pinctrl-names = "default";
|
|
- status = "disabled";
|
|
+ status = "okay";
|
|
};
|
|
|
|
/* TODO: write binding */
|