nonguix/nongnu/packages/patches/fallout1-ce-fpattern.patch
Rodion Goritskov dca524777a
nongnu: Add fallout1-ce and fallout2-ce.
* nongnu/packages/game-development.scm (fallout1-ce): New variable.
* nongnu/packages/game-development.scm (fallout2-ce): New variable.
* nongnu/packages/game-development.scm (fpattern): New variable.
* nongnu/packages/game-development.scm (fury): Fix indentation.
2024-11-06 00:14:18 +04:00

19 lines
554 B
Diff

Originally fallout1-ce has the fpattern library bundled in the repo.
This patch unbundles it.
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd50a9e..afdb04c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -353,7 +353,9 @@ else()
find_package(SDL2)
endif()
-add_subdirectory("third_party/fpattern")
+find_path(FPATTERN_INCLUDE_DIR fpattern.h)
+find_library(FPATTERN_LIBRARY libfpattern.so)
+
target_link_libraries(${EXECUTABLE_NAME} ${FPATTERN_LIBRARY})
target_include_directories(${EXECUTABLE_NAME} PRIVATE ${FPATTERN_INCLUDE_DIR})