nonguix/nongnu/packages/patches/fallout2-ce-fpattern.patch
Rodion Goritskov dca524777a
nongnu: Add fallout1-ce and fallout2-ce.
* nongnu/packages/game-development.scm (fallout1-ce): New variable.
* nongnu/packages/game-development.scm (fallout2-ce): New variable.
* nongnu/packages/game-development.scm (fpattern): New variable.
* nongnu/packages/game-development.scm (fury): Fix indentation.
2024-11-06 00:14:18 +04:00

18 lines
578 B
Diff

Originally fallout2-ce has the fpattern library bundled in the repo.
This patch unbundles it.
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2de2af1..f6c6ace 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -360,7 +360,8 @@ if(APPLE)
set(MACOSX_BUNDLE_BUNDLE_VERSION "1.3.0")
endif()
-add_subdirectory("third_party/fpattern")
+find_library(FPATTERN_LIBRARY libfpattern.so)
+find_path(FPATTERN_INCLUDE_DIR fpattern.h)
target_link_libraries(${EXECUTABLE_NAME} ${FPATTERN_LIBRARY})
target_include_directories(${EXECUTABLE_NAME} PRIVATE ${FPATTERN_INCLUDE_DIR})