putex/package.nix
2024-07-24 22:00:37 -05:00

19 lines
287 B
Nix

{ lib, rustPlatform }:
with builtins;
with lib;
let cargoToml = (fromTOML (readFile ./Cargo.toml));
in
rustPlatform.buildRustPackage rec {
pname = cargoToml.package.name;
version = cargoToml.package.version;
src = ./.;
cargoLock = {
lockFile = src + /Cargo.lock;
};
}